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Introduction

What is Aqua4Push?

Aqua4Push is INW’s data collection and upload program. It is designed to run
continuously and collect data at user-selectable intervals from a network of INW Smart
Sensors. Optionally, Aqua4Push sends a data file to an FTP site after each collection.
The collected data is then available via the Internet from anywhere in the world.

When running, Aqua4Push:
• “Wakes up” at the specified interval

• Optionally, turns on any needed relays

• Takes readings from all sensors

• Turns off relays

• For pressure sensors, optionally makes adjustments based on barometric
pressure

• Appends to a monthly data file

• Optionally, uploads the data to an FTP site

For test purposes, the program can be set into a test mode where it will take readings
every five minutes. Also, you can force a single reading/upload at any time.

You can use Aqua4Plus (INW’s Smart Sensor Control Program) while Aqua4Push is
running. If you are running a program, such as Aqua4Plus, that uses the same COM
port, and it gets close to time for the next reading, a message will pop up warning that a
reading is soon scheduled. If you continue to run the other program, the reading will
simply be skipped.

An error log is maintained on the local machine. Errors are logged whenever a sensor
cannot be read and whenever an upload is unsuccessful.

System Requirements

• Desktop or  laptop computer, running Windows 98 or higher.

• 128 MB RAM

• 20 MB free hard drive space

• CDROM drive

• 9-pin serial port or USB port

• Optional modem or Internet connection. (Note: If you are using an IP modem, you
will also need the COM redirection program. Contact INW for details.)
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Getting Started

Quick Overview

The following steps are needed to install and configure an Aqua4Push sensor network.
Each step is explained in detail in the following sections.

• Install Aqua4Push and Aqua4Plus

• Set Sensors and Radios with Aqua4Plus

• Connect Sensors and Radios

• Create or Edit Sensor Map

• Set Polling Schedule

• Select Sensor Map

• Initialize Network

Installing Aqua4Push and Aqua4Plus

Installing Aqua4Push

1. Insert the Aqua4Push CD in the CDROM drive on your PC or laptop. Installation
should start automatically. If not, then follow steps 2 and 3. Otherwise, skip to
step 4.

2. Click the Start button and select Run.
3. Type D:\setup.exe, where D: is the drive letter for your CDROM drive.
4. The Installation program will guide you through the installation process.

Once the software has successfully completed installation, you can remove the CD from
your CDROM drive and store it in a safe place.

Installing Aqua4Plus

Aqua4Plus is INW’s Smart Sensor Control Software. Use it for initial set up of your
network and for background data recording.

1. Insert the Aqua4Plus CD in the CDROM drive on your PC or laptop. Installation
should start automatically. If not, then follow steps 2 and 3. Otherwise, skip to
step 4.

2. Click the Start button and select Run.
3. Type D:\setup.exe, where D: is the drive letter for your CDROM drive.
4. The Installation program will guide you through the installation process.

Once the software has successfully completed installation, you can remove the CD from
your CDROM drive and store it in a safe place.
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Setting the Sensors and Radios with Aqua4Plus

Use INW Aqua4Plus Control Software to view the individual sensors and radios that
will be in your network. To start Aqua4Plus, use the Start Menu to navigate to the
program group you selected during installation (typically this will be Aqua4Plus), and

then click the Aqua4Plus  icon.

If needed, use Aqua4Plus to set addresses on each sensor. Every sensor and radio on
your network must have a unique address. Note that host radios are always address 1.
You can also, at this point, set any sensor or channel labels descriptions, if desired. (See
the Aqua4Plus Control Software Instruction Manual and specific hardware manuals for
setup details for each type of sensor and radio.)

IMPORTANT!
If INW supplied a pre-configured Sensor Map, the addresses and descriptions
on your sensors and radios should match those in the Sensor Map. (See page 6
for details in viewing and/or changing the Sensor Map, if needed.)

Connecting Sensors and Radios

Aqua4Push collects data from a number of INW Smart Sensors, including:
• PT2X Pressure/Temperature Sensor

• PT2X-BV Barometric Sensor

• TempHion pH/ISE/Redox Sensor

• CT2X Conductivity/Temperature Sensor

• T16 Smart Temperature Sensor.

• GDL Smart Datalogger

For specific installation details on each sensor type, refer to their corresponding
manuals. Networks of sensors can be connected in one of several ways. (See Appendix
A for sample network wiring diagrams.)

• Directly to a PC

• Via a dial out modem on the PC to a cellular modem at the sensor site

• Via an Internet connection to a cellular IP modem at the sensor site

• Via a WaveData Collection network.
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Creating and Editing Sensor Maps

Overview
Aqua4Push is designed to work with specific sensor addresses and descriptions. This
information is stored in a file called a Sensor Map. This file controls such things as what
sensor addresses are polled, the types and names of sensors found on each of those
addresses, which COM port to use, and various other parameters. It also controls the
polling interval.

Sensor Maps are created and maintained using the Sensor Map Editing utility. You can
have several different Sensor Maps, each with a different name, and you can switch
between them, if you want to use your computer at different sites, or if you have several
different configurations you want to use at one site. The files must have an extension of
.inf and can be saved anywhere on your hard drive.

Creating and Editing Sensor Maps
A word about “Connections” is in order at this point. Aqua4Push is designed to be able
to poll not only sensors connected directly to your computer, but also sensor networks
connected via cell modems or radios. The Sensor Map utility has an expanding tree
window that lists each Connection, and under each Connection, it lists each sensor that
is connected in that network. For example, you might have one network of sensors
directly connected to your computer via a COM port and another network of sensors
connected via a cell modem. The following section will describe how to create and edit a
Sensor Map.

To create or edit a Sensor Map, start Aqua4Push -- use the Start Menu to navigate to
the program group you selected during installation (typically this will be Aqua4Push),

and then select the Aqua4Push   icon. If you get a message about not finding a

valid Sensor Map file or about the network not being initialized, simply close the
message. Open the File menu, and then select either New Sensor Map (to create a
Sensor Map) or Edit Sensor Map (to edit an existing Sensor Map).  The letters in the
following descriptions refer to figures 1 through 4.

Upon opening the Sensor Map utility, a list of connections will display on the left hand
side of the panel, as shown below. (If you are creating a new file, this panel will be
blank.)

Click on the + in front of each connection to expand the tree (C). The tree will then
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Figure 1: Sensor Map Utility - Connections Panel

display the connections (D) and the sensors (E) that are under each connection.

Adding/Editing/Deleting Connections
To create a new connection, click the Add Connection button (F). If you want to edit an
existing connection click on that connection on the connection tree in the left panel.
Enter or edit the information in the right hand panel, as follows:

(I) Select the connection type.
For sensors that connect directly to your COM port or for a network whose
base station radio is directly connected to your COM port, select Direct. For
sensors that connect via a dial up modem, select Modem. For sensors that are
connected via an IP modem, select IP Modem.

(J) Enter a name for your connection. This should be something that will help you
identify the location.

(K) If you selected a connection type of Modem, enter the telephone number for
the modem you are calling, including a 1 and the area code, if needed. If you
need to dial a 9 or another access code, enter that at the beginning, followed by
two or three commas. (Commas provide a slight pause before the next digit.)
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For example: 9,,,1 206 333 3333.
(L) Enter the name you want for the data file for this connection. Each connection

will have its own data file. If you leave this blank, a file name based on the
connection name will automatically be generated.

(N) If you have a direct connection, enter the COM port that your sensors are
connected to. If you are using a dial out modem, enter the COM port for your
modem. If you are using an IP modem, enter the COM port that has been
assigned to that modem using a COM redirection program. (Contact INW for
details on a recommended COM redirection program.)

(O) Default Settings: From the dropdown box, select communication settings for
this  type of connection. This will set the timeout and retry values that are
recommended for particular types of settings.

(P) The retry level is how many times the program will retry a particular command
before giving up and treating it as an error. This value is automatically set
when you select a Default Setting. It can be changed here, if needed.

(Q) The timeout level is how long the program waits for a response from a sensor
before trying again or giving up as an error. This value is automatically set
when you select a Default Setting. It can be changed here, if needed.

(R) If you are using WaveData radios anywhere in your network, check the Enable
Remote Radio Wakeup box. This will send out a special command to wake up
any radios that are in power saving sleep mode before attempting to
communicate with the sensors. Do not use the Radio Repeater Mode, unless
instructed to do so by INW.

(V) If you will be uploading your data to an FTP site, click on the Upload
Information tab to display the Upload Information panel. Enter the requested
information. Click on the Communication Options tab (M) to return to the main
connections panel.

Figure 2: Upload Information Panel

For Direct connections.
For WaveData radio connections
For Modem and IP Modem connections
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Figure 3: Sensor Map Utility - Sensor Panel

(S) Click the Cancel button if you want to cancel adding or changing this
connection.

(T) If you are done with the changes for this connection, click the Save button.
(H) To delete a connection, click on the connection in the left panel and then click

the Delete button.
(W) If you want to temporarily stop taking readings from a particular connection or

sensor, uncheck the checkbox in front of that connection or sensor. To begin
taking readings from that connection or sensor again, simple re-check the box.

(U) When you are done making changes to the Sensor Map, click the Close button.

Adding/Editing/Deleting Sensors
To add a new sensor to an existing connection, click on that connection, and then click
the Add Sensor button (G). If you want to edit an existing sensor, click on that sensor on
the tree in the left panel. Enter or edit the information in the right hand panel, as follows:

(V1) From the Type dropdown box, select the sensor type.
(V2) Enter a name for your sensor. This should be something that will help you



10

identify the sensor. Ideally, this should be the same name that is assigned to
the sensor in Aqua4Plus.

(V3) Enter the sensor address. (If you are unsure of the sensor address, use
Aqua4Plus to scan for the sensor. Move the mouse over the sensor on
Aqua4Plus’s sensor tree. The sensor address will show in a popup tool tip.)

(V4) If you have a PT2X-BV (barometric sensor) in your network, Aqua4Push can
automatically apply barometric compensation to any PT2X measurements. To
specify that the selected sensor is the barometric sensor to be used in these
calculations, checkmark the second box. To specify that this sensor’s readings
are to be barometrically compensated, checkmark the first box. (Note, you must
have a barometric sensor higher in the tree than the first sensor you want
compensated.) If you are not using barometric compensation, leave both these
boxes unchecked.

(S) Click the Cancel button if you want to cancel adding or changing this sensor.
(T) If you are done with the changes for this sensor, click the Save button.
(H) To delete a sensor, click on the sensor in the left panel and then click the Delete

button.
(U) When you are done making changes to the Sensor Map, click the Close button.

Setting Polling Schedule

The Sensor Map is also used to control the polling schedule. If the Sensor Map is not
open, select Edit Sensor Map from the File menu. Click on the Scheduling tab (B). When
running, Aqua4Plus will take readings from all sensors on all connections at each polling
time. You cannot have different schedules for different sensors or connections. You can
have different schedules in different Sensor Maps. Set the polling information as
follows:

(B1) Select the base polling frequency. In other words, will you be taking readings
every few seconds, every few minutes, daily, monthly, etc.

(B2) From the Start Time dropboxes, select the time the polling is to start in hours,
minutes, and seconds. Note: use 24 hour time.

(B3) Refine your polling interval. For instance, if your base polling frequency is in
minutes, enter the number minutes from the start of one reading to the start of
the next. (Note: some readings may take several seconds, depending on how
many sensors you are polling, and whether you are using radios. If you are
using a number of cell modems and have a number of connections, it may take
several minutes to complete a reading. If the polling interval is set lower than
the amount of time it takes to make a reading, the readings will simply be taken
one right after the other.)

(T) When you have set the polling interval, click the Save button.
(A) Click the Connections and Sensors tab, if you want to return to the main

Sensor Map panel.
(U) If you are done making changes to the Sensor Map, click the Close button.



11

Figure 4: Sensor Map Utility - Sensor Panel

Selecting the Sensor Map

To select an existing Sensor Map, open the File menu, and then click on Select Sensor
Map.

Initializing the Network

Before Aqua4Push can actually begin to take readings, it must initialize the network.
During network initialization, the program connects to and reads each sensor that is
listed in your Sensor Map file. It reads certain setting and calibration information from
the sensors that it will need to use during readings. It combines this information with
various other information from your Sensor Map file, including the polling schedule, to
set up an internal control file that will control when and how to take readings.
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The very first time you run Aqua4Push, you may get the following message:

This means that no Sensor Map has yet been selected. Close this message box. From
the File Menu, click on New Sensor Map to create a new Sensor Map. (See previous
section for information on creating Sensor Maps.) Once the map has been created, or if
you already have a valid Sensor Map elsewhere on your hard drive, click on Select
Sensor Map, navigate to that map, and click Open. If the network has not yet been
initialized for this Sensor Map, the following message will appear.

Click okay to begin initialization. If you do not want to initialize at this time, click Cancel.
You can force an initialization at any time from the Options menu. If you want to initialize
all the connections in that Sensor Map, select Initialize - All. If you only want to initialize
a particular connection in the Sensor Map, click on the connection you want to initialize,
and then select Initialize - Selected. Any connections that are not initialized will be
shown in red on the main Aqua4Push window. Any readings taken will ignore
uninitialized connections.

If initialization is successful, the initialized connections will display in black on the main
Aqua4Push window and no error messages will appear. You are now ready to begin
taking readings.
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If initialization is not successful, the following dialog box will display.

If the program is unable to verify the network, check the following:
• Check cable connections - Are all cables firmly attached?

• If using radios, check radio power - Is power turned on to all radios?

• Check that all radios have a clear line-of-sight path back to the master radio.
(Refer to the WaveData Instruction Manual for radio trouble-shooting
information.)

• Check the Sensor Map - Is it configured the same way your network is wired?
(See previous section for further details on Sensor Maps.)

• Is the correct COM port selected in the Sensor Map?

• Radio and modem communication can be slow. If all of the above check out
and you are using radios or modems, you can increase the Timeout Level for
any affected connections in the Sensor Map. The Timeout Level is the time
the program waits before deciding that communication has failed. In the same
way, you can also increase the Retry Level. This is the number of times the
program will try to take a reading before deciding it can’t.

• If you believe the Sensor Map is correct, and the connections and settings
appear to be correct, refer to the trouble shooting section later in this manual
for more information.
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(A) Time for next reading
(B) Various status messages displayed here
(C) Current time
(D) List of connections, sensors and radios in your network
(E) Click on the Display Reading button to display, but not record, a reading for

the selected connection.
(F) Various details for the selected sensor or radio.
(G) Click here for the sensor address and additional details on the selected sensor.
(H) Display of times and values read. Note: when reading all connections, only the

last connection on the list will be displayed.

Figure 5:  Main Aqua4Push Window

Standard Operation

Once Aqua4Push successfully initializes it will begin to take and record readings on the
schedule defined in the Sensor Map file. The main window will display as shown in
Figure 5.
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Aqua4Push is designed to be left running at all times! Minimize it and it will continue to
run in the background, automatically taking readings as scheduled. You can use
Aqua4Plus while this is running. If you are running Aqua4Plus, or any other program
that uses the same COM port, when it gets close to the time to take the next reading, a
message will pop up warning you that a reading is soon scheduled. If you continue to
run the other program, the reading will simply be skipped.

Figure 6: When Minimized, the Program Sits on the Task Bar

Viewing the Data Files

The data files are saved on your local computer, as well as optionally on an FTP site.

Local Data Files
Access the local data files from the File menu by selecting View Data Files. Each
connection has a separate data file. Data is stored on the local machine in monthly files.
The first part of the file name is the same as the file name on the connections panel in
the Sensor Map. This name is then followed by a four digit year and a two digit month.
For example, if the file name in the Sensor Map is Red_River.csv. The file on the
computer will be Red_River_2006-9.csv for the September 2006 data file.

Remote Data Files
Access the data files on the FTP site by using either an FTP client program or via a web
browser.

• Using an FTP Client - follow instructions for your particular FTP client software.
The host is ftp.hostname.

• Using a web browser - Enter ftp://user_id@hostname.
In either case, you will be asked for a userid and a password. Your userid and host name
are listed on the Upload Information panel in the Sensor Map. Each connection has a
separate file name and can be uploaded to a different FTP site, if desired. If you are
uploading to an INW site, INW will supply a password. If you are uploading to your
own site, get the password from your administrator.

Data is stored on the FTP site in monthly files much like it is stored on the local
computer, with one exception. The current file will not have a date extension. Thus your
current file for any specific connection will always be the same. Keeping the current file
name the same makes it easier for another program to automatically grab the current file
to graph the results on a web page or use the data in some other program. On the first
upload of a new month, a year and month extension will be added to the existing file and
a new file will be created  for the current month. (See Figure 7 for sample file names.)
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Figure 7: Files on local computer and on FTP site

File Format
Data is saved in a comma separated value (.csv) format. Data files can easily be read
with any text editor, MS Excel, and most data bases and spreadsheets. The first two
lines of the file contain information from the Sensor Map. The third line contains sensor
and channel column headers.  Sensor names will display as assigned via the Sensor
Map. Channel headers will display as assigned to the sensor via Aqua4Plus. The fourth
line contains the units used for displaying the readings, for example, PSI or Ft H2O. The
following lines consist of data only.  Header lines may be written at later times, if
information in the Sensor Map changes or the units change. You can force a new header
to be written by clicking on the Options menu and selecting Send Map Header to Data
File. You can send a new header to files for all connections or just to the selected
connection.  If for whatever reason, a channel is not read during a reading, that location
in the file will be left blank.

Sample Data Viewed in Excel:

Figure 8: Sample Data Viewed in a Text Editor
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Sample Data Viewed in a Text Editor:

Figure 9: Sample Data Viewed in a Text Editor
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Testing & Trouble Shooting

Display Readings

If you want to view current readings from all sensors on a particular connection, click
the Display Readings button on the Aqua4Push panel. The readings will be displayed
on the panel, but will not be saved to the data file nor uploaded to the FTP site. See
Figure 5 on page 14 for an example of displayed readings.

Test Mode

For testing purposes, Aqua4Push can be put into a test mode that takes readings every
five minutes. It also saves the data to the normal output file and uploads the file to the
FTP site. To initiate the test mode, select Test Mode from the Options menu. When the
test mode is on, the Test Mode option on the menu will have a checkmark in front of it.
Also, there will be a red banner at the top of Aqua4Push stating that it is in the test
mode. To turn off the test mode, simply click on Test Mode on the Options menu to
remove the checkmark. Readings will revert to the normal schedule, as set in the Sensor
Map.

Immediate Update

If you want to see what would be collected in a normal scheduled update for all
connections or a selected connection, you can  force a  reading.  From the Options
menu, select either Immediate Update - All or click on a specific connection and select
Immediate Update - Selected. Aqua4Push will take a reading, save the readings to the
normal output file, and upload the file to the FTP site, if using that function. The
readings will also be displayed on the Aqua4Push panel. You can view the saved
readings from the files saved on the local computer or from the FTP site.

Error  Log

All errors encountered by Aqua4Push are recorded in an error log. To view the log,
select the View Error Log option from the File menu. Each line in the error file will list the
date, time, and an explanation of the error. See Table 1 for an list of common errors along
with possible causes and/or solutions.
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Table 1

  Common Errors and Possible Causes/Solutions

  Common Errors Possible Causes/Solutions

  File Error: calData.inf is invalid Network has not been initialized.
Select a Sensor Map from the File
menu. Program will attempt to
reinitialize the network.

  Initialization of sensor T16-Well5 failed During initialization, the program was
unable to verify a particular sensor.
Be sure that sensor is defined
properly in the Sensor Map. Check
sensor cable connections to be
sure that a good connection exits.

  Unable to initialize network Could not initialize the network.
Check the following:

• Sensor Map correct?
• COM port correct?
• Cable connections OK?
• Timeouts and Retries set

       appropriately?

  Reading sensor values: Check your cable and/or radio
     ** Communications Timeout ** connections.

  Can't read PT2X: PT2X-Well7 Network initialized OK, but now
cannot read a particular sensor.
Check you cable and/or radio
connections.

  Cannot open output file: Be sure you have not left the data
file open after viewing.

  Error: Unable to connect to remote host Cannot connect to FTP host. Be sure
host name, userid, and password
are correct in the Sensor Map.
Be sure your Internet connections
are working.
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Checking Sensor Communication and Addresses

If you believe your Sensor Map is correct, but you are still having trouble initializing the
network, open Aqua4Plus and scan to find all connected sensors and radios. (Refer to
the Aqua4Plus Control Software Instruction Manual.)

If you are able to find all sensors with Aqua4Plus, then your cable, radio, and modem
connections are correct. If you can find everything from Aqua4Plus but not from
Aqua4Push, verify that the same COM port, retry levels, and timeout levels are selected
on both programs.

Use Aqua4Plus to check that the actual sensor addresses match the Sensor Map file.
While the sensors are displayed on the sensor panel of Aqua4Plus, move the mouse
over each sensor and radio and pause momentarily. A tool-tip box will pop up displaying
that sensor’s address (Figure 10). Compare this address to the one in the Sensor Map
file for Aqua4Push. If they do not match, change either the Sensor Map file or reset the
address on the sensor itself. See the Aqua4Plus Control Software Instruction Manual
for details on setting sensor addresses. In either case, when you are done, close
Aqua4Plus and reopen Aqua4Push. Select Initialize -All or Initialize - Selected from the
Options menu.

Figure 10: Aqua4Plus with Sensors Listed and One Address Displayed
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Reference

Menus

File Menu

             Figure 11: File Menu

Options Menu

             Figure 12: File Menu

Manually upload to web.

View the current data files on
the local computer.

View the error log.

Select, create, or edit Sensor
Maps.

Initialize the network - all
connections or the selected
connection.

Write header to data file - all
connections or the selected
connection.

Clear display.

File locations for data files and
Sensor Map - see next page.

Set units - see next page.

Test option - take a reading
every five minutes.

Force an immediate reading
and upload - all connections or
the selected connection.
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Units

From the Options Menu, select Units... to set the
units in which to display your data. This will control
how data is represented on the main window and the
data files. When you change units, a new header line
will automatically be written to the data file, showing
the new units.

File Locations Dialog Box

The File Locations dialog box gives information regarding the location of the current
Sensor Map and the data files on your local computer. To open the File Locations dialog
box, select Files... from the Options Menu.

Figure 14: File Locations Dialog Box

Figure 13: Units Dialog Box
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Appendix A - Sample Network Wiring Diagrams

Following are wiring diagrams for four sample networks. Refer to respective hardware
manuals for information on configuring and using specific sensors, radios, and
modems. Contact INW for further details, if you have questions on configuring your
network.

1. Directly to a PC
2. Via a dial out modem on the PC to a cellular modem at the sensor site
3. Via an Internet connection to a cellular IP modem at the sensor site
4. Via a WaveData Collection network

Sample Network 1:
Directly Connected to PT2X Smart Sensors, T16 Temperature Sensors,
and a Barometric Sensor.

PT2X-BV
Barometric

SensorPC

Serial
Port

RS485/RS232
Adapter

T-16
Temperature

Sensor

Junction
Box

PT2X Pressure Sensors

Communication
Cable

Figure 15: Sample Network 1
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Sample Network 2:
Via a dial out modem on the PC to a cellular modem at the sensor site

SITE TWO

Null Modem Adapter
RS232/485 Adapter

PT2X-BV
Barometric

Sensor

PT2X
Pressure
Sensors

Junction
Box

SITE ONE

 Cellular Modem

Null Modem Adapter
RS232/485 Adapter

T-16
Temperature

Sensor

Junction
Box

PT2X
Pressure
Sensor

 Cellular Modem

Null Modem Adapter
RS232/485 Adapter

PT2X
Pressure
Sensor

SITE THREE

 Cellular Modem

Figure 16: Sample Network 2 - Base Station

Figure 17: Sample Network 2 - Remote Stations

Cell Tower

Internal or
External
Modem

PC

Phone
Company
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Sample Network 3:
Via an Internet connection to a cellular IP modem at the sensor site

SITE TWO

Null Modem Adapter
RS232/485 Adapter

PT2X-BV
Barometric

Sensor

PT2X
Pressure
Sensors

Junction
Box

SITE ONE

IP Cellular Modem

Null Modem Adapter
RS232/485 Adapter

T-16
Temperature

Sensor

Junction
Box

PT2X
Pressure
Sensor

IP Cellular Modem

Null Modem Adapter
RS232/485 Adapter

PT2X
Pressure
Sensor

SITE THREE

IP Cellular Modem

Figure 19: Sample Network 3 - Remote Stations

Figure 18: Sample Network 3 - Base Station

PC

Internet

Cell tower
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Sample Network 4:
Via a WaveData Collection network

PT2X-BV
Barometric

Sensor

PT2X
Pressure
Sensors

WaveData Radio

Junction
Box T-16

Temperature
Sensor

Junction
Box
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Figure 21: Sample Network 4 - Remote Stations

Figure 20: Sample Network 4 - Base Station
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Reordering Information

For sales & service offices, please contact:

Instrumentation Northwest, Inc.
www.inwusa.com

800-776-9355
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SOFTWARE LICENSE & LIMITED WARRANTY/DISCLAIMER
- Aqua4Push

SOFTWARE LICENSE. The seller grants the user a non-exclusive license to use
Aqua4Push (hereafter known as the software), according to the following limitations
and conditions.

The user may install  the software on one or more desktop or laptop computers. All title
and intellectual rights to the software are owned by the seller. No copies may be made or
distributed except as described above. The user may not modify or reverse engineer the
software.

A.   LIMITED WARRANTY. Seller warrants that the software will substantially perform
the functions described in the accompanying written materials for a period of ninety (90)
days from the date of receipt. If the software does not conform to the foregoing
warranty, Seller shall, at Seller’s sole and exclusive option, repair or replace the software
or refund to the user a prorated portion of the license fee paid.

Seller warrants that any hardware accompanying the software will be free from defects in
materials and workmanship under normal use and service for a period of one (1) year
from the date of receipt. Seller’s obligation under this warranty shall be limited to
replacing or repairing the part or parts or, at Seller’s option, the products which prove
defective in material or workmanship within ONE (1) year from the date of delivery,
provided that Buyer gives Seller prompt notice of any defect or failure and satisfactory
proof thereof.   Any defective part or parts must be returned to Seller’s factory or to an
authorized service center for inspection.   Buyer will prepay all freight charges to return
any products to Seller’s factory, or any other repair facility designated by Seller.   Seller
will deliver replacements for defective products to Buyer (ground freight prepaid) to the
destination provided in the original order.   Products returned to Seller for which Seller
provides replacement under this warranty shall become the property of Seller.

Seller’s obligations under this warranty shall not apply to any product with (a) is
normally consumed in operation, or (b) has a normal life inherently shorter than the
warranty period stated herein.

In the event that equipment is altered or repaired by the Buyer without prior written approval by
the Seller, all warranties are void.   Equipment and accessories not manufactured by the Seller are
warranted only to the extent of and by the original manufacturer’s warranty.

THE FOREGOING WARRANTIES ARE IN LIEU OF ALL OTHER WARRANTIES,
WHETHER ORAL, WRITTEN, EXPRESSED, IMPLIED OR STATUTORY.   IMPLIED
WARRANTIES OF FITNESS AND MERCHANTABILITY SHALL NOT APPLY.   SELLER’S
WARRANTY OBLIGATIONS AND BUYER’S REMEDIES THEREUNDER (EXCEPT AS
TO TITLE) ARE SOLELY AND EXCLUSIVELY AS STATED HEREIN.   IN NO CASE WILL
SELLER BE LIABLE FOR CONSEQUENTIAL DAMAGES, LABOR PERFORMED IN
CONNECTION WITH REMOVAL AND REPLACEMENT OF THE SENSOR SYSTEM,
LOSS OF PRODUCTION OR ANY OTHER LOSS INCURRED BECAUSE OF
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INTERRUPTION OF SERVICE.   A NEW WARRANTY PERIOD SHALL NOT BE
ESTABLISHED FOR REPAIRED OR REPLACED MATERIAL, PRODUCTS OR SUPPLIES.
SUCH ITEMS SHALL REMAIN UNDER WARRANTY ONLY FOR THE REMAINDER OF
THE WARRANTY PERIOD ON THE ORIGINAL MATERIALS, PRODUCTS OR
SUPPLIES.

B.   With respect to products purchased by consumers in the United States for personal use, the
implied warranties including but not limited to the warranties of merchantability and fitness for a
particular purpose, are limited to twelve (12) months from the date of delivery.

Some states do not allow limitations on the duration of an implied warranty, so the above
limitation may not apply to you.   Similarly, some states do not allow the exclusion or limitation
of consequential damages, so the above limitation or exclusion may not apply to you.   This
limited warranty gives you specific legal rights; however, you may also have other rights which
may vary from state to state.
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